Opened 15 months ago

Closed 14 months ago

Last modified 12 months ago

#641 closed defect (fixed)

v2v3 conversion generates spurious ` ` inside CDATA in artwork

Reported by: cabo@tzi.org Owned by: krathnayake@ietf.org
Priority: major Milestone:
Component: preptool Version:
Keywords: Cc: lars@eggert.org

Description

Source:

<figure anchor="figure1"><artwork><![CDATA[
NBSP HERE
]]></artwork></figure>

(there is an NBSP after "NBSP" here).
xml2rfc creates proper TXT and HTML from that XML.

However, --v2v3 turns this into

      <figure anchor="figure1">
        <artwork name="" type="" align="left" alt=""><![CDATA[
NBSP&nbsp;HERE
]]></artwork>
      </figure>

Note that the &nbsp; is inside a CDATA section, so it then shown literally in TXT or HTML generated from there.

Attachments (2)

nbsp.xml (11.9 KB) - added by cabo@tzi.org 14 months ago.
XML input
nbsp.v2v3.xml (13.7 KB) - added by cabo@tzi.org 14 months ago.
v2v3 XML output (3.9.1)

Download all attachments as: .zip

Change History (11)

comment:1 Changed 15 months ago by lars@eggert.org

  • Cc lars@eggert.org added

comment:2 Changed 15 months ago by cabo@tzi.org

  • Component changed from v3 vocabulary to preptool

There is no "component" value for the v2v3 converter.
The preptool appears not to have the problem (even when it itself does a v2v3 conversion).

comment:3 Changed 14 months ago by krathnayake@ietf.org

  • Status changed from new to waiting

I could not reproduce this issue with xml2rfc 3.9.1.
Do you still have the same issue with xml2rfc?
If so what's the xml2rfc version?

Changed 14 months ago by cabo@tzi.org

XML input

Changed 14 months ago by cabo@tzi.org

v2v3 XML output (3.9.1)

comment:4 Changed 14 months ago by cabo@tzi.org

I noticed the problem with 3.7.0. Still there with 3.9.1. See attached.

comment:5 Changed 14 months ago by krathnayake@ietf.org

  • Owner set to krathnayake@ietf.org
  • Status changed from waiting to assigned

Thanks, I can reproduce this issue now.
Issue I had earlier was I have ignored the fact it's an actual "NBSP".

comment:6 Changed 14 months ago by krathnayake@ietf.org

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in [4010]:

Remove unicode entity replacement step from v2v3 conversion. Fixes #641. Commit ready for merge.

comment:7 Changed 14 months ago by krathnayake@ietf.org

This was a side effect of replacing few unicode code points with XML entities for editing readability and convenience in v2v3 conversion, because replacement was done on the whole XML file.

comment:8 Changed 14 months ago by cabo@tzi.org

Ouch. Thanks for fixing this.

comment:9 Changed 12 months ago by rjsparks@nostrum.com

Fixed in [4022]:

Merged in [4010] from krathnayake@ietf.org:\n Remove unicode entity replacement step from v2v3 conversion. Fixes #641.

Note: See TracTickets for help on using tickets.