Opened 6 years ago

Closed 6 years ago

#161 closed enhancement (wontfix)

Handling high-volume submissions

Reported by: rob.stradling@… Owned by: rob.stradling@…
Priority: minor Milestone:
Component: rfc6962-bis Version:
Severity: - Keywords:
Cc:

Description

Google's Aviator log recently exceeded its MMD slightly. This was:
"caused by the (non-malicious) actions of some high-volume clients. Aviator's signer could not sequence the submitted certificate chains quickly enough to clear the backlog, exacerbated by the fact our protection against flooding did not activate when expected."
https://groups.google.com/a/chromium.org/d/msg/ct-policy/ZZf3iryLgCo/mi-4ViMiCAAJ

Inspired by OCSP, I think we should add a "tryLater" error code to add-chain and add-pre-chain, so that logs can explicitly communicate the fact that they're currently too busy to accept submissions.

Change History (2)

comment:1 Changed 6 years ago by rob.stradling@…

  • Owner changed from draft-ietf-trans-rfc6962-bis@… to rob.stradling@…
  • Status changed from new to assigned

comment:2 Changed 6 years ago by rob.stradling@…

  • Resolution set to wontfix
  • Status changed from assigned to closed

Ryan and Jacob commented on the PR that "tryLater" is unnecessary, because we already specify that log servers can return 503 Service Unavailable with (optionally) a Retry-After header (see https://github.com/google/certificate-transparency-rfcs/blob/master/draft-ietf-trans-rfc6962-bis-19.txt#L1281-L1294).

Note: See TracTickets for help on using tickets.