Opened 6 years ago

Closed 6 years ago

#147 closed defect (duplicate)

definition of mis-issuance, still!

Reported by: kent@… Owned by: draft-ietf-trans-rfc6962-bis@…
Priority: major Milestone:
Component: rfc6962-bis Version:
Severity: - Keywords:
Cc:

Description

6962-bis fais to define the term that is the cited motivation for CT. Rob changed my ticket (#71) to say that this was a task for the threat analysis doc, but it is a criticism of 6962-bis. The following text, extracted from the threat analysis document, should be added as a new, second paragraph in Section 1.

In the context of Certificate Transparency (CT) certificate mis-issuance is defined to encompass violations of either semantic or syntactic constraints. The fundamental semantic constraint for a certificate is that it was issued to an entity that is authorized to represent the Subject (or Subject Alternative) named in the certificate. (It is also assumed that the entity requested the certificate from the CA that issued it.)

A certificate is characterized as syntactically mis-issued if it violates syntax constraints associated with the class of certificate that it purports to represent. Syntax constraints for certificates are established by certificate profiles, and typically are application-specific. For example, certificates used in the Web PKI environment might be characterized as domain validation (DV) or extended validation (EV) certificates. Certificates used with applications such as IPsec or S/MIME have different syntactic constraints from those in the Web PKI context.

Change History (1)

comment:1 Changed 6 years ago by melinda.shore@…

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of ticket:71

Note: See TracTickets for help on using tickets.