Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#32 closed defect (fixed)

Editorial changes for REQ draft from Phil Eardley

Reported by: kempf@… Owned by: kempf@…
Priority: minor Milestone:
Component: nohost-req Severity:
Keywords: REQ draft Cc: netlmm@…

Description

Section 1.0, last sentence 'architecture of' -> 'problem statement for' & delete 'Section 4 of'

Suggested Resolution: Section 4 of the PS draft does, in fact, talk about the architecture and the consensus at IETF 65 was that the REQ draft also needs to mention it. Since having two different descriptions of the architecture in two different places isn't a good idea on editorial grounds, I'd suggest we keep this reference.

2.0 Suggested minor re-phrasing of first para: <Section 2 of [1] describes three problems with using a global mobility management protocol for localised mobility management. Any localized mobility management protocol must naturally address these three problems. In addition, the side effects of introducing such a solution into the network need to be limited. In this section, we address goals on a localized mobility solution including both solving the basic problems (Goals 1, 2, 3) and limiting the side effects (Goals 4+).>

Suggested Resolution: Accept

2nd para Add resilience to the list.

Suggested Resolution: This was also suggested by Fred Templin. Accept.

'minimal goal for specialized' -> 'minimal specialized'

Suggested Resolution: Accept

Most of the "Goals" sections end with a nice summary para "The goal is that...." Please could all Goals have such a para. [sorry I don't have suggested text]

Suggested Resolution: At IETF 64, it was suggested to add a summary paragraph, so I did. If you are unhappy with the current text, please suggest a substitute. Otherwise, I'd suggest keeping the text as is.

2.5 title 'Reduction of' -> 'Limit the' [otherwise the reader wonders 'reduction from what?']

Suggested Resolution: Yes, since there is currently no standardized solution, there is no point of comparision. Accept.

2.6 2nd para 'In a host based approach, the mobile node is required to have a global or restricted routing local IP address for a network infrastructure element, the mobility anchor point.' ---> If the mobile node was involved, then it would need to have a global or restricted routing local IP address for a network infrastructure element, such as the mobility anchor point.' ['host based approach' may be confused with micromobility protocols, which are sometimes called host-based]

Suggested resolution: In general, use of subjunctive language in technical documentation is to be discouraged. How about: "If the mobile node is involved, then it needs to have a global or restricted routing local IP address fo a network infrastructure element, such as a mobility anchor point"?

2.8 1st sentence, delete ' "IP mobility" (which means'

Suggested Resolution: Accept.

2nd para, 1st sentence, delete 'with a localized mobility management solution that does not have mobile node involvement.'

Suggested Resolution: Accept

9.3.1 title MIPv6 + FMIPv6 -> MIPv6 with local home agent + FMIPv6

Suggested Resolution: Accept

9.4 2nd para, delete 'along a path back to a boundary router at the edge of the localized mobility management domain. A boundary router is a kind of localized mobility management domain gateway.' [this isn't true for Hawaii, which routes to the cross-over router not the gateway. Similarly not true for other micromobility protocol]

Suggested Resolution: The point is that the routers between the crossover router and the access router must be running HAWAII. At some point, they won't. That's the gateway. Gateway here doesn't mean a gateway to the Internet or anything like that, it means a gateway between a network running a standard IGP/EGP and a network running a micromobility protocol. This is how it is defined in the PS document.

4th para 'Cellular IP and HAWAII differ in a few aspects....' I had several detailed question about the content of this para. Rather than listing them, my main point is that I don't think the para adds anything and can be safely deleted.

Suggested Resolution: The point of this discussion is to summarized how the micromobility protocols provide localized mobility management and not a detailed comparison of the micromobility protocols. Accept.

After the end of the 2nd para up to the end of 9.4, and again in the summary table in 9.6, all refs to 'micromobility protocols' should be replaced by 'Cellular IP and Hawaii'. The statements may or may not be true for other micromobility protocols.

Suggested Resolution: This point came up earlier on the NETLMM mailing list. The discussion here and in the PS draft was intended to encompass protocols that have, in the past, been brought up as potential candidates for standardization in IETF. Other protocols (and I know there are a lot of them), while of interest from an academic standpoint, are not relevent to the discussion of getting a standards track protocol. Perhaps the first paragraph of Section 9.4 should say something like "when we talk about micromobility protocols, we mean Cellular IP and Hawaii because they have been proposed for standardization in the past".

Change History (3)

comment:1 Changed 13 years ago by kempf@…

  • Status changed from new to assigned

comment:2 Changed 13 years ago by kempf@…

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed.

comment:3 Changed 12 years ago by anonymous

  • Milestone milestone2 deleted

Milestone milestone2 deleted

Note: See TracTickets for help on using tickets.