Opened 11 years ago

Closed 11 years ago

#162 closed defect (fixed)

Thomas Walsh's Review

Reported by: twalsh@… Owned by: lear@…
Priority: major Milestone: milestone1
Component: draft-iab-rfc3356bis Version: 1.0
Severity: In WG Last Call Keywords:
Cc:

Description


From: Thomas Walsh <twalsh@…>
Date: Wed, May 23, 2012 at 2:06 PM
Subject: [IAB] Response to the IAB Call for Comment: "IETF and ITU-T Standardiation Sector Collaboration Guidelines"
To: "iab@…" <iab@…>

Dear IAB,

I support the current activity to modify the RFC 3356 and would like to submit the following comments regarding the revised version of RFC-3356bis.
I hope these comments are helpful. Please let me know if you require any clarifications.

Regards,

Tom Walsh

---
Comments on draft –iab-rfc3356bis-01

Comment #1 - Changes to Title
The title of the document should accurately reflect the content. The document addresses communication between the organizations and not actual collaboration. Collaboration would be a more complex subject such as that outlined in ITU-T Recommendation A.23 between ISO and ITU-T and collaborations require formal agreement. This document does not address that level of detail. Therefore, replace “Collaboration” in the title with “Communication”.

Comment #2. - Changes to Abstract
The Abstract should explain the document is about communication not collaboration guidelines between ITU-T and IETF and that it is informational in nature and not normative. The current abstract is therefore not a correct representation of the document.

Comment #3. - Scope
Since this is not a Normative document, the scope can be eliminated and merged with the Introduction section.

Comment #4. - Introduction

  • Add the scope sentence with the change of “Collaboration” to “Communication”. In general, the references to “collaboration” should be a global change to “communication” throughout the document.
  • Delete the rest of the Introduction as it off topic. This also simplifies the text.


Comment # 5. -Section 3

  • This section needs to be greatly simplified. It should merely refer to the written liaison procedures in each body.


  • Change title to Guidance on “Communication”


  • Communication between ITU-T and IETF is handled by Liaison. The liaison procedures in each body are well established and therefore all this section needs to do is point to the respective procedures in each organization.


  • Delete the first sentence in Section 3 and replace it with “Communication between ITU-T and IETF is handled by Liaison. ITU-T Liaison procedures are found in XXXX and IETF liaison procedures are found in YYYY”.


  • Most of the text in the rest of section 3 can either be deleted or replaced by simple reference to the procedures in each body.


  • It is important to note if ITU-T liaises a Draft Recommendation or text to the IETF, this document is now public.


  • It should also be noted that Liaisons appointed by IETF to the ITU-T may register either as “ISOC” or under their own company’s sector membership. In either case, when fulfilling their liaison responsibility, they speak only to the communication of information and they are not empowered to make binding agreements on behalf of their body. Nor are they empowered to make binding agreements on their sector member they registered with.


Comment #6- The text in following sections and subsections can be deleted:

3.1 How to interact with ITU-T or IETF work items
3.1.1 How the IETF is informed about existing IETF work items
3.1.2 How the ITU is informed about proposed new work items
3.1.3 How the IETF is informed about ITU-T work items


Comment #7 -3.2 Representation
Replace this section with the following text:

“Liaisons appointed by IETF to the ITU-T may register either as “ISOC” or under their own company’s sector membership. When fulfilling their liaison responsibility, Liaisons speak only to the communication of information between ITU-T and IETF. They are not empowered to make binding agreements on behalf of their SDO or the sector member they registered with.”

  • Replace the text in the rest of 3.2 with references to procedures.


Comment #8 – Section 3.3 Document Sharing
-Delete the first paragraph as it is off topic
-Add a statement that ITU-T documents liaised to IETF become public

Comment #9 Section 3.5 Preliminary work efforts
Delete section 3.5 as it pertains to collaboration and not communication

###

Response from Eliot:

From: Thomas Walsh <twalsh@…>
Date: May 23, 2012 2:06:50 PM PDT
To: "iab@…" <iab@…>
Subject: [IAB] Response to the IAB Call for Comment: "IETF and ITU-T Standardiation Sector Collaboration Guidelines"

Dear IAB,

I support the current activity to modify the RFC 3356 and would like to submit the following comments regarding the revised version of RFC-3356bis.
I hope these comments are helpful. Please let me know if you require any clarifications.

Regards,

Tom Walsh

---
Comments on draft –iab-rfc3356bis-01

Comment #1 - Changes to Title
The title of the document should accurately reflect the content. The document addresses communication between the organizations and not actual collaboration. Collaboration would be a more complex subject such as that outlined in ITU-T Recommendation A.23 between ISO and ITU-T and collaborations require formal agreement. This document does not address that level of detail. Therefore, replace “Collaboration” in the title with “Communication”.

While the relationship with the ITU-T cannot be described as entirely friendly, "Communication" doesn't really cover all the ground in what is written, unless it is proposed that we and they not attend each others' meetings. We've already substantially modified text, and I believe, taken a lot of the language that Tom might also find objectionable. I am concerned that going any farther would make it all too painfully clear that we are downgrading the relationship. Perhaps We may do just that if we cannot find common ground, but I would like it not done through the title of A.supp3. The overall tone of Tom's comments is that we should in fact downgrade the relationship. That being the case we are better off retiring the agreement. Even he has not proposed that.


Comment #2. - Changes to Abstract
The Abstract should explain the document is about communication not collaboration guidelines between ITU-T and IETF and that it is informational in nature and not normative. The current abstract is therefore not a correct representation of the document.

See above.


Comment #3. - Scope
Since this is not a Normative document, the scope can be eliminated and merged with the Introduction section.

We've merged introduction and scope. I don't object to removing the word "scope" from the intro, but in fact we might want to go the other way, and explain that this document explains the existing processes of both organizations and how they map across.


Comment #4. - Introduction

  • Add the scope sentence with the change of “Collaboration” to “Communication”. In general, the references to “collaboration” should be a global change to “communication” throughout the document.
  • Delete the rest of the Introduction as it off topic. This also simplifies the text.

Already worked on with the rewrite for Bernard.


Comment # 5. -Section 3

  • This section needs to be greatly simplified. It should merely refer to the written liaison procedures in each body.

Hopefully we have already provided the symmetry that Adrian and others were looking for. I'd suggest we've gone as far as we could go.


  • Change title to Guidance on “Communication”

See above.


  • Communication between ITU-T and IETF is handled by Liaison. The liaison procedures in each body are well established and therefore all this section needs to do is point to the respective procedures in each organization.

Unfortunately we can't do that. There is a gap at least in as much as we are neither an A.4 or A.6 qualified organization. That was by design.


  • Delete the first sentence in Section 3 and replace it with “Communication between ITU-T and IETF is handled by Liaison. ITU-T Liaison procedures are found in XXXX and IETF liaison procedures are found in YYYY”.

Again, on their side, this is XXXX.


  • Most of the text in the rest of section 3 can either be deleted or replaced by simple reference to the procedures in each body.

See above.


  • It is important to note if ITU-T liaises a Draft Recommendation or text to the IETF, this document is now public.

I believe we've covered this ground.


  • It should also be noted that Liaisons appointed by IETF to the ITU-T may register either as “ISOC” or under their own company’s sector membership. In either case, when fulfilling their liaison responsibility, they speak only to the communication of information and they are not empowered to make binding agreements on behalf of their body. Nor are they empowered to make binding agreements on their sector member they registered with.

I believe we have covered the ground in the first sentence. I generally like the idea of the second sentence. What do other people think? I think the third sentence is none of our business- they may actually be empowered to make binding agreements on behalf of their sector members. What do we know?


Comment #6- The text in following sections and subsections can be deleted:

3.1 How to interact with ITU-T or IETF work items
3.1.1 How the IETF is informed about existing IETF work items
3.1.2 How the ITU is informed about proposed new work items
3.1.3 How the IETF is informed about ITU-T work items

Propose reject. This is the key aspect of reducing strife.


Comment #7 -3.2 Representation
Replace this section with the following text:

“Liaisons appointed by IETF to the ITU-T may register either as “ISOC” or under their own company’s sector membership. When fulfilling their liaison responsibility, Liaisons speak only to the communication of information between ITU-T and IETF. They are not empowered to make binding agreements on behalf of their SDO or the sector member they registered with.”

See above.

  • Replace the text in the rest of 3.2 with references to procedures.

See above.


Comment #8 – Section 3.3 Document Sharing
-Delete the first paragraph as it is off topic

Propose reject. Informal communication is quite necessary.

-Add a statement that ITU-T documents liaised to IETF become public

This is already present.


Comment #9 Section 3.5 Preliminary work efforts
Delete section 3.5 as it pertains to collaboration and not communication

Again, propose reject. Preliminary work efforts are where we can avoid strife early.

Change History (1)

comment:1 Changed 11 years ago by lear@…

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.