Opened 11 years ago

Closed 9 years ago

#39 closed editorial (fixed)

ETag uniqueness

Reported by: mnot@… Owned by: julian.reschke@…
Priority: normal Milestone: 10
Component: p4-conditional Severity: Active WG Document
Keywords: Cc:

Description

From experience I think it's also worthwhile to further stress the importance of ETag uniqueness among variants of a URI. Very few implementations get this part correct. In fact most major web servers have issues here...

Some even strongly believe that entities with different Content-Encoding is the same entity, arguing that since most encoding (at least the standardized ones) can be converted to the same identity encoding so they are in fact the same entity and should have the same strong ETag.

Attachments (1)

i39.diff (6.3 KB) - added by julian.reschke@… 9 years ago.
Proposed example

Download all attachments as: .zip

Change History (18)

comment:1 Changed 11 years ago by mnot@…

  • Component set to conditional
  • Milestone set to unassigned

comment:2 Changed 11 years ago by mnot@…

  • version set to 00-draft

comment:3 Changed 11 years ago by mnot@…

  • Type changed from design to editorial

comment:4 Changed 11 years ago by julian.reschke@…

Proposal:

Strong entity tags MUST be unique for each representation of a particular resource; they must change if the representation varies over time and/or because of the use of server-driven content negotiation.

comment:5 Changed 11 years ago by julian.reschke@…

  • Owner set to julian.reschke@…

comment:6 Changed 11 years ago by julian.reschke@…

  • Milestone changed from unassigned to 04

comment:7 Changed 11 years ago by mnot@…

  • Type changed from editorial to design

proposal is for inclusion in p4 section 7.1. However, need WG buy-in for adding a new requirement; flipping to design.

comment:8 Changed 11 years ago by julian.reschke@…

  • Milestone changed from 04 to unassigned

comment:9 Changed 10 years ago by mnot@…

  • Milestone changed from unassigned to 06

comment:10 Changed 10 years ago by julian.reschke@…

  • Milestone changed from 06 to unassigned

comment:11 Changed 10 years ago by henrik@…

The problem is basically isolated to Content-Encoding. For the other aspects most seem to get it right.

Suggested resolution is to add an informal example showing Content-Encoding negotiation responses, and with a note on why the ETag is different.

This issue is also somewhat related to the terminology discussion.

comment:12 Changed 10 years ago by mnot@…

  • Priority set to normal
  • Severity set to Active WG Document
  • Type changed from design to editorial

comment:13 Changed 9 years ago by julian.reschke@…

1st step:

add example showing how etag differs for Content-Encoding: gzip and no Content-Encoding. Explain that things would be different for Transfer-Encoding.

Changed 9 years ago by julian.reschke@…

Proposed example

comment:14 Changed 9 years ago by julian.reschke@…

From [800]:

Add an example for an ETag varying based on the Accept-Encoding (related to #39)

comment:15 Changed 9 years ago by julian.reschke@…

  • Milestone changed from unassigned to 10
  • Resolution set to incorporated
  • Status changed from new to closed

comment:16 Changed 9 years ago by mnot@…

  • Resolution incorporated deleted
  • Status changed from closed to reopened

comment:17 Changed 9 years ago by mnot@…

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.