Opened 10 years ago

Closed 10 years ago

#243 closed editorial (fixed)

Not clear whether server SHOULD or MUST send a response

Reported by: esko.dijk@… Owned by: esko.dijk@…
Priority: minor Milestone: post-WGLC-1
Component: coap Version: coap-11
Severity: In WG Last Call Keywords:
Cc:

Description

For unicast requests received by a server: Section 5.8.1 / 5.8.3 / 5.8.4 seem to state that a response SHOULD be sent by a server, or at least it can be read in this manner (I did). Section 5.8.2 (POST) seems to implicitly state that it MUST respond with something. Section 5.2 states "After receiving and interpreting a request, a server responds with a CoAP response" which seems to imply a MUST.
Is there a unified statement possible? E.g. for unicast requests a response MUST be generated, regardless of REST Method?

Change History (4)

comment:1 Changed 10 years ago by hartke@…

-> Make a pass through the document and make sure that the key word refers to the response code of the response being returned, not to whether a response is returned at all. Any volunteers?

comment:2 Changed 10 years ago by esko.dijk@…

Message received by email on Wed, 05 Sep 2012 10:19:57 +0000, inserted by email2trac:

I, at least, volunteer to do a pass through the document.
A possible next step is add a clarification text to section 5.2 saying that
"a server MUST respond with a CoAP response, apart from the exceptions stated
in section 8.2".

I know that in RFC 2616 also no 'MUST' language is used for a HTTP response,
but on the other hand HTTP does not have the multicast to confuse these
matters a bit.

Esko

-----Original Message-----
From: core-bounces@ietf.org [mailto:core-bounces@ietf.org] On Behalf Of core
issue tracker Sent: Tuesday 4 September 2012 17:08 To:
draft-ietf-core-coap@tools.ietf.org; hartke@tzi.org Cc: core@ietf.org
Subject: Re: [core] #243: Not clear whether server SHOULD or MUST send a
response

#243: Not clear whether server SHOULD or MUST send a response

Comment (by hartke@…):

 -> Make a pass through the document and make sure that the key word refers
 to the response code of the response being returned, not to whether a
 response is returned at all. Any volunteers?

--
-------------------------+-------------------------------------
 Reporter:  esko.dijk@…  |       Owner:  draft-ietf-core-coap@…
     Type:  editorial    |      Status:  new
 Priority:  minor        |   Milestone:
Component:  coap         |     Version:
 Severity:  -            |  Resolution:
 Keywords:               |
-------------------------+-------------------------------------

Ticket URL: <http://tools.ietf.org/wg/core/trac/ticket/243#comment:1>
core <http://tools.ietf.org/core/>

_______________________________________________
core mailing list
core@ietf.org
https://www.ietf.org/mailman/listinfo/core

________________________________
The information contained in this message may be confidential and legally
protected under applicable law. The message is intended solely for the
addressee(s). If you are not the intended recipient, you are hereby notified
that any use, forwarding, dissemination, or reproduction of this message is
strictly prohibited and may be unlawful. If you are not the intended
recipient, please contact the sender by return e-mail and destroy all copies
of the original message.

comment:3 Changed 10 years ago by hartke@…

  • Milestone set to post-WGLC-1
  • Owner changed from draft-ietf-core-coap@… to esko.dijk@…
  • Severity changed from - to In WG Last Call
  • Version set to coap-11

comment:4 Changed 10 years ago by hartke@…

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [881]:

Fixes #243 . Thanks Esko!

Note: See TracTickets for help on using tickets.